Topic: Gem/authentication problems

Hi, I'm having some trouble with the devise gem. Installing works fine:

gem install devise

Then, in my application directory I try to generate:
script/generate devise_install

Which gives me this:

Missing these required gems:
  warden  = 0.5.1
  devise  = 0.4.1

I have had similar problems with several other authentication gems (authlogic etc) I've tried; missing, not working, etc. It is strange because I can see them in ~\ruby\gems\gems. Not sure if this is related, but I've also had problems with just about every other gem package I've tried (I don't believe I'm using any gems right now). However, the other problems might just be separate issues.

For reference:
ruby 1.8.6
rails 2.3.5

*edit: For example, I also have some problems with nifty-generators

Last edited by asfarley (2011-02-01 04:45:12)

Re: Gem/authentication problems

Maybe you use the old version Ruby and Rubygems. Try use Ruby minimum 1.8.7 and Rails 2.3.8.

Re: Gem/authentication problems

*edit* I'm not able to update versions on my current host (hostingrails.com) without going through some hassle. In my opinion it's possible that it's their fault, but I'm not really able to say for certain. I will post the results when they get back to me.

Last edited by asfarley (2011-02-01 05:45:21)