Topic: restful_authentication not working with IE (Internet Explorer)

I used the restful_authentication, and it works fine on Firefox, and any other browser except Internet Explorer.  Every time someone uses IE it shows up with a Windows basic autentication login pop-up.  Has anyone else had this problem?

I have before_filter :login_required on the top of the controller.

Here is a screen shot of the login that shows up on IE.

http://www.columbianahosting.com/login.png

Re: restful_authentication not working with IE (Internet Explorer)

Has anyone else had this problem?

Re: restful_authentication not working with IE (Internet Explorer)

I also get the login screen when using the restful_authentication plugin.
When filling in the username/password I can login.

Is the login screen your problem or you cannot login ?

Re: restful_authentication not working with IE (Internet Explorer)

yea - when I enter the correct username and password it does not work.  I get the following error:

HTTP Basic: Access denied.

But if I use FireFox or another browser and get to the login page the same username and password works.

Re: restful_authentication not working with IE (Internet Explorer)

I have the same problem. Does anyone has a solution?

Re: restful_authentication not working with IE (Internet Explorer)

try to empty the cache

Re: restful_authentication not working with IE (Internet Explorer)

Is anyone still seeing this problem? I just installed Parallels, accessed localhost:3000 directly through the IP address, and Google Chrome, Firefox, Opera all work fine. However, IE 6 hits the http authentication (although, it drops back to the login_path if I click 'cancel') whereas IE7 just hits http authentication and won't go to the login form at all. 

Can I expect this to happen on any machine running IE, or is it just down to accessing running Parallels on Shared Networking and Mongrel through the IP address?

Re: restful_authentication not working with IE (Internet Explorer)

And here we have two potential fixes (I opted for number one, from the man himself);

http://groups.google.com/group/rubyonra … 7?lnk=raot

http://www.ruby-forum.com/topic/157730#new

Now I just need to wrestle with IE7. Funnily enough, IE6 has done a much better job with my CSS (but, let's not beat around the bush, both have messed it up - big time).

Re: restful_authentication not working with IE (Internet Explorer)

Well, this from long ago but the problem still exist today even in the latest version of the IE. I think IE is has a big problem with restful_authentication I just don’t know what it is. So now, while I am using restful_authentication I am using Firefox or google chrome but not IE.


Try our indianapolis seo with seo services