Topic: Could not find gem 'mysql2 (>= 0)'

when I run command "rails server" in terminal I get this prompt
"Could not find gem 'mysql2 (>= 0)' in any of the gem sources listed in your Gemfile."
Instead of

" info WEBrick..."

I made sure my gems were installed correctly

any suggestions? thanks everyone

Re: Could not find gem 'mysql2 (>= 0)'

try running
gem install mysql2 -- --with-mysql-config=/usr/bin/mysql_config

replace /usr/bin/mysql_config with whatever the path is to your mysql_config file

What you want and what you need are too often not the same thing!
When your head is hurting from trying to solve a problem, stop standing on it. When you are the right way up you will see the problem differently and you just might find the solution.
(Quote by me 15th July 2009)

Re: Could not find gem 'mysql2 (>= 0)'

I came up with this

Reason: image not found - /Library/Ruby/Gems/1.8/gems/mysql2-0.3.2/lib/mysql2/mysql2.bundle

sorry, I am just getting the hang of programing after a 10 year sabatical. Thank you for all of your support

Re: Could not find gem 'mysql2 (>= 0)'

Hello jamesw, i could not install gem mysql2 yet. I use the XAMPP on Mac OS, then my "mysql_config" is in "/Applications/XAMPP/xamppfiles/bin/mysql_config". Following what you told, I did "gem install mysql2 -- --with-mysql-config=/Applications/XAMPP/xamppfiles/bin/mysql_config", but didn't worked.

Last edited by rogerbenevento (2011-08-06 16:43:58)