Topic: "role :app, server" results in "wrong number of arguments"

Hey everybody

To remove duplication I'd like to change this...

set :server, 'muheimwebdesign.ch'
role :web, 'muheimwebdesign.ch'
role :app, 'muheimwebdesign.ch'
role :db,  'muheimwebdesign.ch', :primary => true

...to...

set :server, 'muheimwebdesign.ch'
role :web, server
role :app, server
role :db,  server, :primary => true

...but sadly this results in...

macbuech:Source josh$ cap deploy
./config/deploy.rb:13:in `server': wrong number of arguments (0 for 1) (ArgumentError)
    from ./config/deploy.rb:13:in `load'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:172:in `load_from_file'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:89:in `load'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:86:in `load'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:86:in `each'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:86:in `load'
    from Capfile:4:in `load'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:172:in `load_from_file'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:89:in `load'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:86:in `load'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:86:in `each'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/configuration/loading.rb:86:in `load'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/cli/execute.rb:65:in `load_recipes'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/cli/execute.rb:65:in `each'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/cli/execute.rb:65:in `load_recipes'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/cli/execute.rb:31:in `execute!'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/lib/capistrano/cli/execute.rb:14:in `execute'
    from /Library/Ruby/Gems/1.8/gems/capistrano-2.6.0/bin/cap:4
    from /usr/bin/cap:19:in `load'
    from /usr/bin/cap:19

Any idea why this doesn't work?

Thank you, Josh