Topic: Problem with Ruby1.9.2 and Phusion Passenger

I've got a little problem with ruby1.9.2 and phusion passenger. The Problem is, that the page never finishes loading. The real problem with this is, that none of the log files are reporting anything unusual. I already raised the loglevels of apache and passenger to report everything, but apache isn't logging anything at all, neither does the rails-application-logging and the passenger logging isn't very helpful either:

[ pid=8749 thr=1082411328 file=ext/common/ApplicationPool/Pool.h:939 time=2011-03-22 11:18:17.693 ]: Spawning a process for /srv/www/htdocs/projects/appname because there are none for this app group
[ pid=8749 thr=1082411328 file=ext/common/ApplicationPool/../SpawnManager.h:291 time=2011-03-22 11:18:17.693 ]: Spawning a new application process for /srv/www/htdocs/projects/appname...
[ pid=8754 thr=47291517534880 file=ext/common/LoggingAgent/LoggingServer.h:899 time=2011-03-22 11:18:20.647 ]: Flushing all sinks (periodic action)

The last message keeps repeating every minute or so.
This doesn't effect only the one application, but all of them. I don't think it's a problem with the configuration or something, cause when I use ruby1.8.7 instead and don't change anything else, it works exactly the way it's supposed to. I already tried different versions of apache and passenger, but without any success. The only thing that helps is to use ruby1.8.7. Here's some info about the server, we're using:
The operating-system is SLES10, apache-version 2.2.3, rails 3.0.5(3.0.3 and 3.0.4 aren't working either).
Has someone else come cross that problem and knows a solution or can help me to get a little more output or information on the error?!

So long,

Re: Problem with Ruby1.9.2 and Phusion Passenger

Replying to an old thread, but I spent a few hours debugging this and I hope this saves someone that trouble.
My apache error_log file was constantly filling up with messages like these every minute or so, causing disk space problems.
[ pid=11390 thr=47071500954560 file=ext/common/LoggingAgent/LoggingServer.h:824 time=2011-08-15 11:15:57.733 ]: Flushing all sinks (periodic action)

<br/>[ pid=11390 thr=47071500954560 file=ext/common/LoggingAgent/LoggingServer.h:824 time=2011-08-15 11:16:12.733 ]: Flushing all sinks (periodic action)

The simple solution was to change the PassengerLogLevel to 0,1 or 2 in your apache httpd.conf (I had mine in conf/extra/httpd-vhosts.conf)<br/>

Following is a snippet of my httpd-vhosts.conf (yours might be in httpd.conf) <br/><br/>

PassengerLogLevel 1<br/><br/>

<VirtualHost *:80><br/>
  DocumentRoot /opt/phusion/www <br/>
  RackBaseURI /prservices <br/>
  <Directory "/opt/phusion/www"> <br/>
    Options -Indexes FollowSymLinks <br/>
    AllowOverride AuthConfig FileInfo <br/>
    Order allow,deny <br/>
    Allow from all <br/>
  </Directory> <br/><br/>

</VirtualHost><br/><br/> … pache.html <br/>
5.13.1. PassengerLogLevel <integer> <br/>

Last edited by bhayzone (2011-08-15 14:27:00)

Re: Problem with Ruby1.9.2 and Phusion Passenger

Hello bhayzone,

thanks for the answer smile
My problem weren't exactly those logs. The main problem was, that no project worked at all. The browser just never finished loading. I just noticed those log entries and thought, there may be a connection. I guess there wasn't smile Seems like a lot of people get these entries if debug-logging is enabled.
For future reference: my problem was solved with