Topic: How to install attachment_fu

Beginner's problem.

I found some tutorials describing how to install the plugin, but it doesn't work on my side:

anwoitasch@Vienna-Linux:~/Programmierung/railsprojects/rim2011/script$ ruby script/plugin install git://github.com/technoweenie/attachment_fu.git
ruby: No such file or directory -- script/plugin (LoadError)


If I skip the 'ruby' at the beginning or start with ./script/plugin ... it also doesn't work.
I'm on Rails 3.0.3

Last edited by anwoita (2011-08-23 15:04:35)

2

Re: How to install attachment_fu

It looks like you are trying to run "script/plugin" from the script directory which is probably why you are getting the "No such file.." error. Try the same command from the rim2011 directory.

BTW, attatchment_fu doesn't appear to work with rails 3.

https://github.com/technoweenie/attachment_fu/issues/17

Re: How to install attachment_fu

@bp: thanks for the information.

Now, I have chosen Carrierwave and it seems to work.