Topic: Capistrano precompile error

Hi all,

Im trying to get my application to deploy but im stuck at this error:

executing "cd /var/www/my_app/live/releases/20110921200802 && bundle exec rake RAILS_ENV=production RAILS_GROUPS=assets assets:precompile"
    servers: ["xx.xx.xx.xx"]
    [xx.xx.xx.xx] executing command
*** [err :: xx.xx.xx.xx] rake aborted!
*** [err :: xx.xx.xx.xx] /var/www/my_app/live/releases/20110921200802/config/initializers/session_store.rb:3: syntax error, unexpected ':', expecting $end
*** [err :: xx.xx.xx.xx] ...sion_store :cookie_store, key: '_my_app_session'
*** [err :: xx.xx.xx.xx] ^
*** [err :: xx.xx.xx.xx] 
*** [err :: xx.xx.xx.xx] Tasks: TOP => environment
*** [err :: xx.xx.xx.xx] (See full trace by running task with --trace)
*** [err :: xx.xx.xx.xx] 
    command finished in 1894ms

My session_store.rb is completely default:

# Be sure to restart your server when you modify this file.

MyApp::Application.config.session_store :cookie_store, key: '_my_app_session'

# Use the database for sessions instead of the cookie-based default,
# which shouldn't be used to store highly confidential information
# (create the session table with "rails generate session_migration")
# MyApp::Application.config.session_store :active_record_store

Anyone know how to solve this?

Thanks!

Re: Capistrano precompile error

Ok. Seriously, i've been working on this issue for about 2 hours. And 5 mins after i posted this solved it.

Incase anyone bump into this:

Add the following to the beginning of your deploy.rb

# setup rvm
$:.unshift(File.expand_path('./lib', ENV['rvm_path']))
require 'rvm/capistrano'
set :rvm_ruby_string, '1.9.2-p290'
set :rvm_type, :root