Topic: rails3, with passenger setup "No route matches" for assets

i've setup a new rails development environment, using the multi-user rvm setup and mod passenger using Apache. I installed ruby 1.9.2 as my default ruby and installed the rails3 gem. I also created a new rails3 project.

Now when i want go to the url of my new project i get to see the rails welcome page (the page that you get when you create a new project). But i don't see the image (rails.png). When i try to go to the png using my browser i get the following error:

    No route matches [GET] "/assets/rails.png"

I can't find out why. I also tried running the project with WebRick and then everything is ok, it serves the image as it should.

Any idea's what could be wrong, maybe wrong Directory settings in Apache?

These are my Directory settings:

    <Directory /home/projects/rails3/data/rails3/ >
      Order allow,deny
      Allow from all
    </Directory>

When i remove this, i get a forbidden when i try to go to the website.

This is my full vhost config:

    #BEGIN 01start

    <VirtualHost *:80>
    ServerName rails3.titan.kunstmaan.be
    DocumentRoot /home/projects/rails3/data/rails3/public
    
    # END  01start
    
    
    #BEGIN 05aliases
    ServerAlias rails3.titan.kunstmaan.be www.rails3.titan.kunstmaan.be
    
    # END  05aliases
    
    
    #BEGIN 10permissions
    <Directory /home/projects/rails3/data/rails3/public >
      Order allow,deny
      Allow from all
    </Directory>
    
    # END  10permissions
    
    
    #BEGIN 20logging
    ErrorLog /home/projects/rails3/apachelogs/error.log
    CustomLog /home/projects/rails3/apachelogs/access.log combined
    
    # END  20logging
    
    
    </VirtualHost>

thanks,

Daan