Topic: Loggin in to the application does not work during production

Hi there,

I have successfully deployed my application and the front pages of the application work fine. Now when I try logging in by adding my password and email or even pressing the sign up button. I get an error saying "We're sorry, but something went wrong. We've been notified about this issue and we'll take a look at it shortly."

any ideas...?

My web link is http://shwfgf17.ibls.gla.ac.uk/

Thanks
a1aks

Last edited by a1aks (2011-10-24 09:49:25)

Re: Loggin in to the application does not work during production

What Authentication are you using?  What Version of Rails?

Look at the log/production.log file and see what it says.

There should be error messages in there pointing you in the right direction.

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.

Re: Loggin in to the application does not work during production

Check your production.log file, - it will tell you much more or come back with the error stack trace from it.

Re: Loggin in to the application does not work during production

@Brad: sorry you've won in speed smile

Re: Loggin in to the application does not work during production

25 seconds!  A photo finish <:

It's all good,  makes the community seem all the more responsive!

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.

Re: Loggin in to the application does not work during production

I finally got the production.log file from my console and found out the following errors.

130.209.53.216 - - [14/Nov/2011:10:53:18 +0000] "GET /stylesheets/default.css HTTP/1.1" 404 947
130.209.53.216 - - [14/Nov/2011:10:53:18 +0000] "GET /stylesheets/print.css HTTP/1.1" 404 947
130.209.53.216 - - [14/Nov/2011:10:53:24 +0000] "POST /forgot_password HTTP/1.1" 500 948
130.209.53.216 - - [14/Nov/2011:11:23:33 +0000] "POST /forgot_password HTTP/1.1" 500 948
130.209.53.216 - - [14/Nov/2011:11:23:39 +0000] "GET / HTTP/1.1" 304 -
130.209.53.216 - - [14/Nov/2011:11:23:39 +0000] "GET /stylesheets/blueprint/screen.css?1321021222 HTTP/1.1" 304 -
130.209.53.216 - - [14/Nov/2011:11:23:39 +0000] "GET /stylesheets/blueprint/print.css?1321021222 HTTP/1.1" 304 -
130.209.53.216 - - [14/Nov/2011:11:23:39 +0000] "GET /javascripts/dragdrop.js?1321021222 HTTP/1.1" 304 -


Most of the pages that have a GET request functions fine. but those especially the one that has the "forgotten password" is in a POST request and shows the error.

Could this be a routing error or something which is way beyond my head.

Suggestions are welcome.


a1aks

Last edited by a1aks (2011-11-14 07:26:59)

Re: Loggin in to the application does not work during production

Hi BradHodges,

I used the Rails tutorials book by Michael Hartl for my authentication (I assume that it should be the basic one from scratch). and my version is Rails 2.3.9

Also I am using simple_form_for, the plugin by carlosantoniodasilva in GitHub. Should that be doing any problems...?

Also the application works fine in the developmental stage.

Thanks

Last edited by a1aks (2011-11-14 09:57:45)

Re: Loggin in to the application does not work during production

Did you forget to push your public directory to the production site?

Did you run your migrations on the production site?

Did you freeze your plugin into your development site before pushing it up,  or did you install the plugin in the production site?

You realize that when you pushed your site upto production,  then run your migrations up there,  you'll have an empty user database,  so you would need to re-run your first regsitration and establish a new user on the production site,  your test user doesn't nessecarrily get copied upto production UNLES you manually dump the test user database and  load it into production.

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.

Re: Loggin in to the application does not work during production

Hi BradHodges,

Thank you for the response. I figured out my problem. I was not using git as my repository and used svn. My deployment was fine and the reason that caused the error was pertaining to ActionMailer. I had not configured my smpt settings in the production.rb file and hence only during the developmental stage it worked fine...

I am fixing the problem but I confirm that there was no mistake with the deployment.

Thanks for the suggestions
a1aks

Last edited by a1aks (2011-11-17 16:42:11)

Re: Loggin in to the application does not work during production

Hi.,
I integrate dicom in my rails application that purpose i install RMagick gem then the following errors are  came.

C:\Ruby187\bin>gem install RMagick
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
ERROR:  Error installing RMagick:
        ERROR: Failed to build gem native extension.

        C:/Ruby187/bin/ruby.exe extconf.rb
checking for Ruby version >= 1.8.5... yes
Invalid drive specification.
Unable to get ImageMagick version
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby187/bin/ruby


Gem files will remain installed in C:/Ruby187/lib/ruby/gems/1.8/gems/rmagick-2.1
3.1 for inspection.
Results logged to C:/Ruby187/lib/ruby/gems/1.8/gems/rmagick-2.13.1/ext/RMagick/g
em_make.out

can any one please suggest me a proper solution.

Thank you.

Re: Loggin in to the application does not work during production

http://rubyforge.org/projects/rmagick/

get the RMagick-Win32 gem

gem install rmagick-win32

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.