Topic: Error trying to use Active Admin

I was able to install the gem activeadmin and it runs fine on localhost.
When I git push to heroku, I get the following error:

-----> Preparing app for Rails asset pipeline
       Running: rake assets:precompile
       rake aborted!
       could not connect to server: Connection refused
       Is the server running on host "127.0.0.1" and accepting
       TCP/IP connections on port 5432?

I'm wondering if it has to do with the instructions:
1. Setup default url options for your specific environment. Here is an
     example of development environment:
     config.action_mailer.default_url_options = { :host => 'localhost:3000' }

4. If you are deploying Rails 3.1 on Heroku, you may want to set"
       config.assets.initialize_on_precompile = false 

I can't find where to put those 2 lines of code.

Thanks

Last edited by reddirt (2011-12-11 15:58:14)

Re: Error trying to use Active Admin

Got it fixed.  I had to pre-compile some files.