Topic: Authlogic + rails 3.2

Hi! I have installed authlogic to handle My authorization and have done like the tutorials for Rails 3. I think the most works beside the login page, user_sessions#new it doesn't render.
Does anyone know what the problem could be?

Re: Authlogic + rails 3.2

Hi there tGoesRails,

My apologies, although without more information it is hard to base reasoning behind this.

Since I see you're using Rails 3.2 - you're definitely on the right track. Are you using store location? If so, this does not preserve form data. Also, browsers typically do not allow redirecting to POST request, which browsers have you tested this on? Does it work on any of them? Can you submit a code snippet so we can view what and where the issue lies?

I again truly apologize if I am missing any important data you've enclosed, so if that is the case, please feel free to point that out.

Re: Authlogic + rails 3.2

I have followed this turtorial: http://joelgreutman.com/2011/03/13/rail … asic-setup
but i deleted the migration for UserSessions.

All i see in the login page is

Re: Authlogic + rails 3.2

Hello again,

My apologies for the delay, I seem to have forgotten about this post.

I have replicated this on my end and have seen the issue with mongrel loaded. Please try this with passenger if possible, as I believe you are using mongrel - there is an issue with Rails 3 and mongrel.

http://www.modrails.com/install.html

If this does not work still, can you upload your code snippets or provide a link to the issue (screenshot will work too, not sure if posting your sites links here is cool)