Topic: Assets Precompile issue after starting server

After deploying the application in production, I started the server and hit the root url but I got assets precompile error in browser.

Sprockets::Helpers::RailsHelper::AssetPaths::AssetNotPrecomiledError in User_sessions#new

application.js isn't precompiled.

To get rid of this, I executed the following command in console:
bundle exec rake assets:precompile

But now I got the following error in console with rake aborted:

Invalid CSS after  "": expected selector, was ""
  (in C:/zynapp/app/assets/stylesheets/application.css)

rake aborted!


Any help?

When you feel the entire world is against you, there is a little voice in the back of your head that keeps saying... "You can do it, I know you can" That is because you can ♥

Re: Assets Precompile issue after starting server

post the contents of C:/zynapp/app/assets/stylesheets/application.css

then show a listing of every file that is in C:/zynapp/app/assets/stylesheets

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.

Re: Assets Precompile issue after starting server

Thanx BradHodges!

The problem was in my other stylesheet. Since we have require_tree structure in our latest versions of rails, so every css was
included in application stylesheet. Though, it was difficult to search each stylesheet for a particular error as by looking at error
message it was giving the intuition that the error is in application css. The exact css for the error was excluded in the console.

When you feel the entire world is against you, there is a little voice in the back of your head that keeps saying... "You can do it, I know you can" That is because you can ♥