Topic: Rails (devise,omniauth)

Hi,Im new to this forum.

Im having a problem on a simple facebook connect.
I tried to follow all the tutorial on the website but its not work for me.

gem using : devise ,omniAuth
rails version : 3.0.7

I want to ask what rails version ,devise version, omniAuth version is gud to use to apply in my application? It come to my mind because i tried out some of the tutorial, they need omniAuth of lower version like 0.1.x or 0.2.x .

I would like to seek some help/advice that what is the gud gem for me to use to connect facebook. I chose to use omniAuth cz it can apply on multiple account such as google ,facebook and etc. Is that im on the correct path?

currently im refering tutorial :

http://www.communityguides.eu/articles/16
https://github.com/plataformatec/devise … A-Overview
https://github.com/plataformatec/devise … :-Overview
http://railscasts.com/episodes/235-omniauth-part-1

Re: Rails (devise,omniauth)

oh ya i have to add on that, when i connect ,mostly it will generate an error

SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed

i tried to solve by referring online solution,but for window,i do exactly the same,but it still the same

Link i refering:
http://stackoverflow.com/questions/5720 … on-windows
https://gist.github.com/867550

Re: Rails (devise,omniauth)

i solved the problem thanks !
For window user:
Firstly,you have to go for the official cert website to download the latest cert then put at your config fonder , /config/ca-bundle.crt

and then go to your omniauth.rb
for configuration
  provider :facebook, 'apikey' , 'secret', :client_options => { :ssl => { :ca_file => "#{Rails.root}/config/ca-bundle.crt" } }