Topic: Error during installation and code generation

Hello all,

I think I had some problems with installing different version of RoR etc...

Then I followed the process here:

http://net.tutsplus.com/tutorials/ruby/ … -on-a-mac/

and now I have the 1.9.2 version.

Still, I had these error:

/Users/lotfideveloper/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/lib/rails/generators/app_base.rb:254: warning: Insecure world writable dir /usr/local in PATH, mode 040777
/Users/lotfideveloper/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/bundler.rb:255: warning: Insecure world writable dir /usr/local in PATH, mode 040777


during the installation and when I try to just generate a demo project with : rails new demo.

I don't know if these errors are important or not... but I would like to have a clean and stable environment...

any help?

THanks a lot.

Re: Error during installation and code generation

It's just alerting you that your /usr/local directory has permissions set to 777. You can make the error go away by doing a chmod to change the permissions, for example:

$ sudo chmod 755 /usr/local  

The permissions you set, and how important it is, really depends on whether your computer is set up as a web server. For more info, check out http://en.wikipedia.org/wiki/Chmod

Last edited by Brian71 (2012-03-25 15:00:52)