Topic: rvm use 1.9.3 error

[jak@jak-laptop ~]$ rvm use 1.9.3

RVM is not a function, selecting rubies with 'rvm use ...' will not work.
[jak@jak-laptop ~]$ 

I hear it's because I have to add a line to the .bashrc file but none of the lines I've found so far are working sad

Last edited by marsters256 (2012-03-24 19:13:04)

Re: rvm use 1.9.3 error

I think this might be a problem with my .rvm/script/rvm file
I get this output when i source it

[jak@jak-laptop ~]$ source .rvm/scripts/rvm
find: paths must precede expression: /home/jak/.rvm/hooks
Usage: find [-H] [-L] [-P] [-Olevel] [-D help|tree|search|stat|rates|opt|exec] [path...] [expression]

any ideas?

Re: rvm use 1.9.3 error

Do you have this in your .bashrc file?

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" # Load RVM into a shell session *as a function*

This worked for me in Ubuntu 11.10.

Re: rvm use 1.9.3 error

Brian71 wrote:

Do you have this in your .bashrc file?

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" # Load RVM into a shell session *as a function*

This worked for me in Ubuntu 11.10.

Yeah, and the .bashrc file runs the rvm file and it then gives me the error that I mentioned

Re: rvm use 1.9.3 error

what do you get when you do a "which rvm"?

Re: rvm use 1.9.3 error

/home/myusername/.rvm/bin/rvm

when i go

 source /home/myusername/.rvm/bin/rvm

i get

Re: rvm use 1.9.3 error

...you mean that you still get the same error as above?

what do you get with these?

$ type rvm | head -1
$ type -t rvm

Worst case, you can always uninstall/reinstall. RVM is easily uninstalled with:

$ rvm implode

For installation, I think Step 2 on this page is a pretty good set of instructions:
http://blog.sudobits.com/2011/10/27/how … ntu-11-10/

Last edited by Brian71 (2012-03-25 16:41:52)