Topic: require 'cgi' in production environment

I use the method "CGI.escape" in a helper class - so I bind using require 'cgi' the appropriate lib.

In the development environment (OS X 10.7, Ruby 1.9.3, Rails 3.1.3, WEBrick) everything works as expected.

In the production environment (Ubuntu 10, Ruby 1.9.3, Rails 3.1.3, Apache2, Phusion Passenger) I get my app when restarting a LoadError for the Lib cgi.

When I was in the production environment, the Ruby console (irb) run and require 'cgi'  -> "true".

In the Rails console (rails c) but I get a "false".

I'm thankful for every tip.

Marco

Last edited by MarcoMarkl (2012-04-06 08:15:44)