Topic: sqlite3 1.3.6 on ruby 1.9.3p125 [i386-mswin32_90]

I failed to get gem install sqlite3 to work using the VC command prompt. So I downloaded the gem file sqlite3-1.3.6-x86-mswin32-60.gem from http://rubygems.org/gems/sqlite3/versio … mswin32-60 and did a local gem install.

So now on gem list shows an entry
sqlite3 (1.3.6 x86-mswin32-60).

I want to update my Gemfile to pick up this gem rather than trying to install the gem sqlite3 whose native extensions do not build on VC compiler.

While I noticed that with a mingw compiled version of ruby, having the following line in my Gemfile.lock file is sufficient,

sqlite3 (1.3.6-x86-mingw32)

a similar thing i.e.

sqlite3 (1.3.6-x86-mswin32-60)

is not working with mswin compiled version of ruby

What changes should I make in my Gemfile or Gemfile.lock for it to pick the above mentioned gem?
Any help will be much appreciated

Last edited by sushma_s (2012-06-14 08:07:09)