Topic: Problem to run rails 3.2.6 server on ubuntu

HI all
I'm a vb.net developer,so I'm new with ubuntu and ROR
i tried to run rails server and i got this error
test@test-945GCM-ubuntu:~/myapp$ rails s
/home/test/.rvm/gems/ruby-1.9.2-p320/gems/execjs-1.3.2/lib/execjs/runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/execjs-1.3.2/lib/execjs.rb:5:in `<module:ExecJS>'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/execjs-1.3.2/lib/execjs.rb:4:in `<top (required)>'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in `require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in `require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
    from /home/test/.rvm/gems/ruby-1.9.2-p320@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in `require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in `block (2 levels) in require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in `each'
    from /home/test/.rvm/gems/ruby-1.9.2-p320@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in `block in require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in `each'
    from /home/test/.rvm/gems/ruby-1.9.2-p320@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in `require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320@global/gems/bundler-1.1.3/lib/bundler.rb:119:in `require'
    from /home/test/myapp/config/application.rb:7:in `<top (required)>'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/railties-3.2.6/lib/rails/commands.rb:53:in `require'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/railties-3.2.6/lib/rails/commands.rb:53:in `block in <top (required)>'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/railties-3.2.6/lib/rails/commands.rb:50:in `tap'
    from /home/test/.rvm/gems/ruby-1.9.2-p320/gems/railties-3.2.6/lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'
test@test-945GCM-ubuntu:~/myapp$
Any help  smile

Re: Problem to run rails 3.2.6 server on ubuntu

Hi
add this two gems in your gemfile
gem 'execjs'
gem 'therubyracer'
and then run your server
it will be work................................

Re: Problem to run rails 3.2.6 server on ubuntu

or just install node.js smile))

Re: Problem to run rails 3.2.6 server on ubuntu

I tried to install node.js with these commands
1) sudo apt-get install g++ curl libssl-dev apache2-utils
2) sudo apt-get install git-core
And it worked just fine, But i have an error with this command
3)git clone git://github.com/ry/node.git
And the Error was
///////////////////////////
test@test-945GCM-ubuntu:~$ git clone git://github.com/ry/node.git
Cloning into node...
github.com[0: 207.97.227.239]: errno=Connection refused
fatal: unable to connect a socket (Connection refused)