Topic: Very frustrated new Rails user

Can someone please explain to me why this issues occurs?  Yes I have googled and seen a million threads about similar problems but not definitive answer why or how it can be fixed.  Here is my issue:

Setting up rails for the first time I created a new app, rails new app.  At some point I decided I wanted to start over again so deleted the directory and recreated it.  Now every time I run the command I get:

$rails new newsletter
Can't initialize a new Rails application within the directory of another, please change to a non-Rails directory first.

This happens in ANY directory I run 'rails new app' I do not understand why this is happening.  My understanding is that rails puts everything in the new project name and changes need to be modified from there. 

I also feel that I should be able to run
$rails new anything

a hundred times and not have anything to worry about, is this wrong?  Can only one project be made at a time or what?

I have tried this solution and it doesnt work, there are NO .bundle files anywhere: … ther-pleas

I have also tried rvm implode and that doesn't help either, I just have to reinstall everything.

The only fix I have had is creating a new user or running the command in a VM, both less then ideal solutions.

I need to get this figured out before I can even get my feet wet sad


Re: Very frustrated new Rails user

What ide are you using? Netbeans, eclipse? Somethig else ?
I suspect this is an eclipse issue. eclipse uses workspaces and it's a right royal pain in the arse. I highly recommend netbeans
drop ito your command line, cd to whatever folder you want to create your new rails app in and make sure it is empty (Make sure there are no hidden fies) then run the command from the command line to generate a new app.

What you want and what you need are too often not the same thing!
When your head is hurting from trying to solve a problem, stop standing on it. When you are the right way up you will see the problem differently and you just might find the solution.
(Quote by me 15th July 2009)

Re: Very frustrated new Rails user

I had this problem once.. I created a rails project on my home folder by mistake. After, I created a "Projects" folder and couldn't create any projects under that.. I see you already looked for .bundle files, and probably has already tried what I'm going to say, but just in case you haven't, try to create the project in other folder out of your $HOME, just to see if the problem happens too..
Maybe it will help somebody to have an ideia..

Re: Very frustrated new Rails user

As James advised, try to not use IDE (at least Eclipse) for creating RoR projects. Some of them are still buggy or have a strange and unexplainable behaviour.
Try  to do it manually from your terminal or console. Sometimes, your terminal or console is not refreshed automatically if you remove a file/folder where you were in. So quit the console and come back again.
If the problem persists, come back with detailed error traces and the steps you followed which will be helpful to observe the problem.

Last edited by Javix (2012-07-19 04:02:24)