Topic: SSL Connection Error. Ruby on Rails.

Hi All,
I'm trying to migrate data from the tables of a remote server to the local database. Though all the configuration looks fine to me, but when I try to run the "rake RAILS_ENV=development demigration:run_cms_migration --trace" , the command fails with:
$ rake RAILS_ENV=development demigration:run_cms_migration --trace
1 ** Invoke demigration:run_cms_migration (first_time)
2 ** Invoke environment (first_time)
3 ** Execute environment
4 ** Execute demigration:run_cms_migration
5 development - demigration:  run_cms_migration
6 rake aborted!
7 SSL connection error: error:00000001:lib(0):func(0):reason(1)
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/mysql2-0.2.6/lib/mysql2/client.rb:37:in `connect'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/mysql2-0.2.6/lib/mysql2/client.rb:37:in `initialize'
/Users/usr/WorkFolder/base/cms-de-migration/lib/tasks/de-migration/run_cms_migration.rake:305:in `new'
/Users/usr/WorkFolder/base/cms-de-migration/lib/tasks/de-migration/run_cms_migration.rake:305:in `connect_dbs'
/Users/usr/WorkFolder/base/cms-de-migration/lib/tasks/de-migration/run_cms_migration.rake:13:in `block (2 levels) in <top (required)>'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:636:in `call'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:636:in `block in execute'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:597:in `block in invoke_with_call_chain'
/Users/usr/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/monitor.rb:211:in `mon_synchronize'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2029:in `block (2 levels) in top_level'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2029:in `block in top_level'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2001:in `block in run'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/bin/rake:31:in `<top (required)>'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/bin/rake:19:in `load'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/bin/rake:19:in `<main>'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
/Users/usr/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'


01 USERs-MacBook-Pro:de-migration User$ ruby -v
02 ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.4.2]
03 Rails 3.0.5
04 USERs-MacBook-Pro:de-migration User$ rvm -v
05
06 rvm 1.14.5 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]
07
08
$ rvm requirements
09
10
  Notes for Mac OS X 10.7.4, Xcode 4.3.3.

Any help will be very much appreciated.
Thanks,
Indy

Last edited by Indyarocks (2012-07-17 03:48:25)