Topic: Installation problem Mac- mapping values not allowed in this context

I'm a Rails newbie and this is my first installation. Using Mountain Lion on a Mac.
I'm getting this response to a number of commands particularly trying to set up a new installation. I installed v1.93 with rvm and also tried running Homebrew.  I did open the psych.rb file to have a look and line 2 is require 'psych/nodes', whatever that means.

Getting this error
rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/psych.rb:203:in `parse': (<unknown>): mapping values are not allowed in this context at line 2 column 8 (Psych::SyntaxError)
and then a list of statements like this
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/psych.rb:203:in `parse_stream'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/psych.rb:151:in `parse'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/psych.rb:127:in `load'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:253:in `load_file'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:191:in `initialize'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems.rb:364:in `new'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems.rb:364:in `configuration'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.0/lib/bundler/rubygems_integration.rb:25:in `configuration'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.0/lib/bundler/rubygems_integration.rb:5:in `initialize'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.0/lib/bundler/rubygems_integration.rb:380:in `new'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.0/lib/bundler/rubygems_integration.rb:380:in `<module:Bundler>'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.0/lib/bundler/rubygems_integration.rb:1:in `<top (required)>'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.0/lib/bundler.rb:7:in `<top (required)>'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /Users/bob/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.0/bin/bundle:2:in `<top (required)>'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/bin/bundle:23:in `load'
    from /Users/bob/.rvm/gems/ruby-1.9.3-p194@global/bin/bundle:23:in `<main>'

Last edited by bobperlman (2012-09-14 02:30:13)