Topic: Help installing rails 3.2.1

Hey everyone. I have rails 3.2.8 installed but I need 3.2.1 installed either paralell with 3.2.8 or permently replacing it. I received work with an existing 3.2.1 site, and the owner does not want to upgrade to 3.2.8.

I downloaded release 3.2.1 from GitHub however I can not figure out how to install it. I tried running the install.rb script, but it fails complaining that it cannot find the .gem files for multiple things (activesupport, activemodel, ... etc).
So I tried running gem install rails --version 3.2.1 and this says it installed rails and I get this output:

Successfully installed rails-3.2.1
1 gem installed
Installing ri documentation for rails-3.2.1...
Installing RDoc documentation for rails-3.2.1...

but I cannot find out where it was installed to.

$ /usr/bin/rails -v
Rails 2.3.14
$ /usr/local/bin/rails -v
Rails 3.2.8
$ ruby -v
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]
$ gem -v
1.8.24

Any help or ideas would be much appreciate! If you need more information please let me know too.
Thanks.

Re: Help installing rails 3.2.1

The best solution to manage multiple Rails and Ruby version is to use RVM. Try to implement it and you will forget if you need yo use sudo, about different config conflicts, etc.