Topic: Almost got it. Small problem with 'Welcome Aboard Page'

've just setup ruby/rails on a centos 6 with passenger and apache. I've got the default 'welcome aboard' page to load but when I click on "About your application’s environment" it shows a 500 internal server error. My database is mysql, I have all the necessary packages installed including the mysql gem. However, everything works as intended in the webbrick server. I can post links to both the apache version with the error and the working webbrick version if anyone cares to see. Any idea what the issue is?

My virtual host file:

<VirtualHost *:80>
  ServerName  simpleurl.co
  # !!! Be sure to point DocumentRoot to 'public'!
  DocumentRoot /var/www/simpleurl.co/http_docs/public
  <Directory /var/www/simpleurl.co/http_docs/public>
     # This relaxes Apache security settings.
     AllowOverride all
     # MultiViews must be turned off.
     Options -MultiViews
     Options -Indexes
  </Directory>
I've added the following to my httpd.conf:

LoadModule passenger_module /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.17/ext/apache2/mod_passenger.so
PassengerRoot /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.17
PassengerRuby /usr/bin/ruby
Link to working webbrick version

Link to broken apache/passenger version

Output from passenger-status:

----------- General information -----------
max      = 6
count    = 0
active   = 0
inactive = 0
Waiting on global queue: 0

----------- Application groups -----------

Last edited by patrickrb (2012-09-27 13:44:16)

Re: Almost got it. Small problem with 'Welcome Aboard Page'

Figured it out.  Had an old Mod_rewrite rule in my httpd.conf   /facepalm