Topic: Rails server fails with [BUG] cross-thread violation on rb_gc()

Created entirely new application with: rails new first_project.
No other edits/changes/commands run.

$ rails s
=> Booting WEBrick
=> Rails 3.2.3 application starting in development on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[BUG] cross-thread violation on rb_gc()
(null)

Searching [BUG] cross-thread violation on rb_gc() results in minimal results and I have no clue why I can't run this project. I've tried multiple different instances of new projects and they all kick out the same error.

I also have another project that I'm collaborating on and am able to run middleman without a hiccup.

Please help, I'm losing my mind over this. Thanks so much!

Re: Rails server fails with [BUG] cross-thread violation on rb_gc()

This could be an issue with ruby environment you have set up.
Check what version of ruby you are using. You may also have a corrupted or bad gem installed. This is not likely going to be anything wrong with your code.

What you want and what you need are too often not the same thing!
When your head is hurting from trying to solve a problem, stop standing on it. When you are the right way up you will see the problem differently and you just might find the solution.
(Quote by me 15th July 2009)