Topic: Unable to install Ruby on Rails 3.x

Dear Sir,

I download the Gem and Ruby v 3.0 from www.ruby.org.

When I try to install using the command

Re: Unable to install Ruby on Rails 3.x

Your post was truncated. Don't forget to indicate the OS you tried to install it.

Re: Unable to install Ruby on Rails 3.x

I used the command "gem install rails".

I am using MAC OS X 10.6.x

The error is as follows:

Building native extensions.  This could take a while...
ERROR:  Error installing rails:
    ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb
mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ruby.h


Gem files will remain installed in /Library/Ruby/Gems/1.8/gems/json-1.7.5 for inspection.
Results logged to /Library/Ruby/Gems/1.8/gems/json-1.7.5/ext/json/ext/generator/gem_make.out

Re: Unable to install Ruby on Rails 3.x

Please install Devkit before you try installing Rails.

Re: Unable to install Ruby on Rails 3.x

Vikas agarwal wrote:

Please install Devkit before you try installing Rails.

thanks for this post ..

Re: Unable to install Ruby on Rails 3.x

i want to install ruby in my LT for practicing the ruby, ruby on rails
MY LT has dual OS , MS XP  and linux red hat
please suggest 1)  which version i need   2) where i can get         3) how to install 4) required configuration of LT

Last edited by rao157 (2012-10-31 06:49:02)