Topic: Runing Server, part of installation process

Hello,

I'm running my firs RoR project and I'm trying to install all to work on my PC, running on XP. I managed to create my firs project but when I need to run server I get error:

so I type: rails server


Otto@deus-eus ~/rails_projects/first_app
$ rails server
/usr/lib/ruby/gems/1.8/gems/sqlite3-1.3.6/lib/sqlite3/sqlite3_native.so: No such process - /usr/lib/ruby/gems/1.8/gems/sqlite3-1.3.6/lib/sqlite3/sqlite3_native.so (LoadError)
        from /usr/lib/ruby/gems/1.8/gems/sqlite3-1.3.6/lib/sqlite3.rb:6
        from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/runtime.rb:68:in `require'
        from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/runtime.rb:68:in `require'
        from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/runtime.rb:66:in `each'
        from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/runtime.rb:66:in `require'
        from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/runtime.rb:55:in `each'
        from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler/runtime.rb:55:in `require'
        from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.22/lib/bundler.rb:122:in `require'
        from /home/Otto/rails_projects/first_app/config/application.rb:7
        from /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:53:in `require'
        from /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:53
        from /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:50:in `tap'
        from /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:50
        from script/rails:6:in `require'
        from script/rails:6

What is wrong? I'm going mad!

Thanks for your help!

Re: Runing Server, part of installation process

You have to install sqlite3 gem

http://accidentaltechnologist.com/ruby- … velopment/