Topic: ERROR: Gem bundler is not installed, run `gem install bundler`(solved)

Hi everyone,

I'm new and I'm getting the (according to my google research) well known

ERROR: Gem bundler is not installed, run `gem install bundler` first.

Of course I have also tried to "gem install bundler", but I wouldn't be here then. I have also tried almost all hints from stackoverflow, but I am pretty sure I have now messed up everything related to ruby.

I'm on a Ubuntu 10.04 64bit machine. Here's some more info

gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.8.24
  - RUBY VERSION: 1.9.3 (2012-11-10 patchlevel 327) [x86_64-linux]
  - INSTALLATION DIRECTORY: /home/roland/.rvm/gems/ruby-1.9.3-p327
  - RUBY EXECUTABLE: /home/roland/.rvm/rubies/ruby-1.9.3-p327/bin/ruby
  - EXECUTABLE DIRECTORY: /home/roland/.rvm/gems/ruby-1.9.3-p327/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /home/roland/.rvm/gems/ruby-1.9.3-p327
     - /home/roland/.rvm/gems/ruby-1.9.3-p327@global
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/
echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/roland/.rvm/bin

Please tell me, what I can do more.

Last edited by roland.d (2012-12-21 11:41:57)

Re: ERROR: Gem bundler is not installed, run `gem install bundler`(solved)

First try **which gem** to see if gem command is installed. If not, then install it using these instructions:
http://docs.rubygems.org/read/chapter/3

Re: ERROR: Gem bundler is not installed, run `gem install bundler`(solved)

Thank you for the fast answer.

which gem
/home/roland/.rvm/bin/gem

Thus, RubyGems is installed. I also already had bundle working. Before, I had the same error too, but I managed to get it working. But I had to install some libs (namely v8, which I unfortunately did using apt-get, among other things). Then I had the bundler not installed error again.
I've tried to uninstall too, but without success.

Last edited by roland.d (2012-12-19 16:06:10)

Re: ERROR: Gem bundler is not installed, run `gem install bundler`(solved)

I've made it: Just reinstall Ubuntu and start all over ^^