Topic: Bundle Install Error? Help!

After adding some gems, I run bundle install and get this error:

Gemfile syntax error: source: rubygems

Here's my Gemfile:

source 'https://rubygems.org'

gem 'rails', '3.2.8'

group :development do
  gem 'sqlite3', '1.3.5'
end

group :assets do
  gem 'sass-rails',   '3.2.5'
  gem 'coffee-rails', '3.2.2'
  gem 'uglifier', '1.2.3'

end

gem 'jquery-rails', '2.0.2'

Re: Bundle Install Error? Help!

ruby -v
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.4.1]

So I think I have the most recent version of Ruby...

Re: Bundle Install Error? Help!

Gemfile seems ok.. it may be due to some conflict with the ruby installed via system package. (check using the command:  which ruby)

Last edited by rkjha (2012-12-26 21:44:13)

Re: Bundle Install Error? Help!

thanks

Re: Bundle Install Error? Help!

using rails '3.2.8'

Re: Bundle Install Error? Help!

After adding some gems, I run bundle install and get this error:

Gemfile syntax error:
group :deve...3.2.7'ygems.org'

Here is my Gemfile:
(I am using ruby 1.9.3p374 and Rails 3.2.7)
-------------------------------------
source 'https://rubygems.org'
gem 'rails', '3.2.7'
group :development do
  gem 'sqlite3', '1.3.5'
  gem 'rspec-rails', '2.10.0'
end
# Gems used only for assets and not required # in production environments by default. group :assets do
  gem 'sass-rails',   '3.2.4'
  gem 'coffee-rails', '3.2.2'
  gem 'uglifier', '1.2.3'
end
gem 'jquery-rails', '2.2.0'
group :test do
  gem 'capybara', '1.1.2'
end
group :production do
  gem 'pg', '0.12.2'
end

Re: Bundle Install Error? Help!

Its nice that you have shared such kind of information here.


---------------------------------

performance management system

Last edited by BobbieIngraham (2013-02-26 13:59:01)