Topic: Installation of Ruby on Rails Fails QNAP TS809U-RP [Linux]

I am attempting to install Ruby on rails and I receive the following when attempting to install rails.  Can someone please help?

[/share/MD0_DATA/Qweb/rubygems-1.8.25] # gem install rails -y
INFO:  `gem install -y` is now default and will be removed
INFO:  use --ignore-dependencies to install only the gems you list
Building native extensions.  This could take a while...
ERROR:  Error installing rails:
        ERROR: Failed to build gem native extension.

        /opt/bin/ruby extconf.rb
creating Makefile

make
/home/slug/optware/ts509/toolchain/i686-unknown-linux-gnu/bin/i686-unknown-linux-gnu-gcc -I. -I/opt/include/ruby-1.9.1/i686-linux -I/opt/include/ruby-1.9.1/ruby/backward -I/opt/include/ruby-1.9.1 -I. -DJSON_GENERATOR -O2   -O2 -I/home/slug/optware/ts509/staging/opt/include  -D_FILE_OFFSET_BITS=64  -fPIC  -O2 -g -Wall -Wno-parentheses  -fPIC -O3 -Wall -O0 -ggdb  -o generator.o -c generator.c
make: /home/slug/optware/ts509/toolchain/i686-unknown-linux-gnu/bin/i686-unknown-linux-gnu-gcc: Command not found
make: *** [generator.o] Error 127


Gem files will remain installed in /opt/lib/ruby/gems/1.9.1/gems/json-1.7.7 for inspection.
Results logged to /opt/lib/ruby/gems/1.9.1/gems/json-1.7.7/ext/json/ext/generator/gem_make.out

Re: Installation of Ruby on Rails Fails QNAP TS809U-RP [Linux]

When I installed Rails on my computer, I followed the instructions from this book http://ruby.railstutorial.org/book/ruby … -rubygems.

Scroll down a little bit and you'll find everything you should need. I did run into a couple problems, though, but they were pretty easy to fix with a few Google searches, and I could try to help if you run into them too.