Topic: How to make rails s working after installing gem 2.3.8 through command

When I type

rails s

in my command prompt. I get following:-

C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rails-2.3.8/lib/rails_gener
ator/options.rb:32:in `default_options': undefined method `write_inheritable_att
ribute' for Rails::Generator::Base:Class (NoMethodError)
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rails-2.3.8/li
b/rails_generator/base.rb:90:in `<class:Base>'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rails-2.3.8/li
b/rails_generator/base.rb:85:in `<module:Generator>'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rails-2.3.8/li
b/rails_generator/base.rb:48:in `<module:Rails>'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rails-2.3.8/li
b/rails_generator/base.rb:6:in `<top (required)>'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo
m_require.rb:55:in `require'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo
m_require.rb:55:in `require'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rails-2.3.8/li
b/rails_generator.rb:37:in `<top (required)>'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo
m_require.rb:55:in `require'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo
m_require.rb:55:in `require'
        from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rails-2.3.8/bi
n/rails:15:in `<top (required)>'
        from C:/RailsInstaller/Ruby1.9.3/bin/rails:23:in `load'
        from C:/RailsInstaller/Ruby1.9.3/bin/rails:23:in `<main>'
Now when i try to access my application via

localhost:3000

I get the following error could not connect to the webserver.Cannot show http://localhost:3000.I actually did rake routes in my command prompt and it suggested me to install gem 2.3.8.After installation of gem 2.3.8 through command prompt, all of this error happened.