Topic: Rails v4 problem with Raspberry Pi

I have Raspberry Pi with Pidora OS. I am using:

  • ruby (1.9.3p194 (2012-04-20 revision 35410) [armv6hl-linux]

  • rails (4.0.0)

When I am trying to run rails I get error:

=> Booting Thin
=> Rails 4.0.0 application starting in development on http://0.0.0.0:3000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
Exiting
/usr/local/share/gems/gems/railties-4.0.0/lib/rails/railtie/configuration.rb:95:in `method_missing': undefined method `active_record' for #<Rails::Application::Configuration:0x28cf0b0> (NoMethodError)
        from /home/user1/RubyOnRails/site1/config/environments/development.rb:23:in `block in <top (required)>'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/railtie/configurable.rb:24:in `class_eval'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/railtie/configurable.rb:24:in `configure'
        from /home/user1/RubyOnRails/site1/config/environments/development.rb:1:in `<top (required)>'
        from /usr/local/share/gems/gems/activesupport-4.0.0/lib/active_support/dependencies.rb:228:in `require'
        from /usr/local/share/gems/gems/activesupport-4.0.0/lib/active_support/dependencies.rb:228:in `block in require'
        from /usr/local/share/gems/gems/activesupport-4.0.0/lib/active_support/dependencies.rb:213:in `load_dependency'
        from /usr/local/share/gems/gems/activesupport-4.0.0/lib/active_support/dependencies.rb:228:in `require'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/engine.rb:591:in `block (2 levels) in <class:Engine>'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/engine.rb:590:in `each'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/engine.rb:590:in `block in <class:Engine>'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/initializable.rb:30:in `instance_exec'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/initializable.rb:30:in `run'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/initializable.rb:55:in `block in run_initializers'
        from /usr/share/ruby/tsort.rb:150:in `block in tsort_each'
        from /usr/share/ruby/tsort.rb:183:in `block (2 levels) in each_strongly_connected_component'
        from /usr/share/ruby/tsort.rb:210:in `block (2 levels) in each_strongly_connected_component_from'
        from /usr/share/ruby/tsort.rb:219:in `each_strongly_connected_component_from'
        from /usr/share/ruby/tsort.rb:209:in `block in each_strongly_connected_component_from'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/initializable.rb:44:in `each'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/initializable.rb:44:in `tsort_each_child'
        from /usr/share/ruby/tsort.rb:203:in `each_strongly_connected_component_from'
        from /usr/share/ruby/tsort.rb:182:in `block in each_strongly_connected_component'
        from /usr/share/ruby/tsort.rb:180:in `each'
        from /usr/share/ruby/tsort.rb:180:in `each_strongly_connected_component'
        from /usr/share/ruby/tsort.rb:148:in `tsort_each'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/initializable.rb:54:in `run_initializers'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/application.rb:215:in `initialize!'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/railtie/configurable.rb:30:in `method_missing'
        from /home/user1/RubyOnRails/site1/config/environment.rb:5:in `<top (required)>'
        from /home/user1/RubyOnRails/site1/config.ru:3:in `require'
        from /home/user1/RubyOnRails/site1/config.ru:3:in `block in <main>'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/builder.rb:55:in `instance_eval'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/builder.rb:55:in `initialize'
        from /home/user1/RubyOnRails/site1/config.ru:in `new'
        from /home/user1/RubyOnRails/site1/config.ru:in `<main>'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/builder.rb:49:in `eval'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/builder.rb:49:in `new_from_string'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/builder.rb:40:in `parse_file'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/server.rb:277:in `build_app_and_options_from_config'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/server.rb:199:in `app'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/commands/server.rb:48:in `app'
        from /usr/local/share/gems/gems/rack-1.5.2/lib/rack/server.rb:314:in `wrapped_app'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/commands/server.rb:75:in `start'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/commands.rb:78:in `block in <top (required)>'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/commands.rb:73:in `tap'
        from /usr/local/share/gems/gems/railties-4.0.0/lib/rails/commands.rb:73:in `<top (required)>'
        from bin/rails:4:in `require'
        from bin/rails:4:in `<main>'

My Gemfile :

source 'https://rubygems.org'
gem 'thin', '1.5.1'
gem 'rails', '4.0.0'
gem 'sqlite3'

My gems:

*** LOCAL GEMS ***

actionmailer (4.0.0, 3.2.14, 3.2.8)
actionpack (4.0.0, 3.2.14, 3.2.8)
activemodel (4.0.0, 3.2.14, 3.2.8)
activerecord (4.0.0, 3.2.14, 3.2.8)
activerecord-deprecated_finders (1.0.3)
activeresource (4.0.0, 3.2.14, 3.2.8)
activesupport (4.0.0, 3.2.14, 3.2.8)
addressable (2.3.5)
arel (4.0.0, 3.0.2)
atomic (1.1.12, 1.1.10)
backports (3.3.3)
bigdecimal (1.2.1)
builder (3.1.4, 3.0.4)
bundler (1.3.5)
coffee-rails (4.0.0, 3.2.2)
coffee-script (2.2.0)
coffee-script-source (1.6.3)
daemons (1.1.9)
diff-lcs (1.2.4, 1.1.3)
erubis (2.7.0)
eventmachine (1.0.3)
excon (0.25.3)
execjs (1.4.0)
heroku (2.40.0)
heroku-api (0.3.14)
hike (1.2.3)
i18n (0.6.4)
io-console (0.4.2)
jbuilder (1.5.0)
journey (1.0.4)
jquery-rails (3.0.4)
json (1.8.0)
launchy (2.3.0)
mail (2.5.4, 2.4.4)
mime-types (1.23)
mini_portile (0.5.1)
minitest (4.7.5)
multi_json (1.7.8, 1.7.7)
multipart-post (1.2.0)
net-http-persistent (2.9)
netrc (0.7.7)
nosql (0.0.2)
polyglot (0.3.3)
rack (1.5.2, 1.4.5)
rack-cache (1.2)
rack-ssl (1.3.3)
rack-test (0.6.2)
rails (4.0.0, 3.2.14, 3.2.8)
rails-observers (0.1.2)
railties (4.0.0, 3.2.14, 3.2.8)
rake (10.1.0)
rake-compiler (0.9.1)
rdoc (3.12.2)
rest-client (1.6.7)
rspec (2.14.1)
rspec-core (2.14.4)
rspec-expectations (2.14.0)
rspec-mocks (2.14.2)
rspec-spies (2.1.4)
rubygems-update (2.0.6)
rubyzip (0.9.9)
sass (3.2.10, 3.2.9)
sass-rails (4.0.0, 3.2.6)
sdoc (0.3.20)
specific_install (0.2.3)
sprockets (2.10.0, 2.2.2, 2.1.3)
sprockets-rails (2.0.0)
sqlite3 (1.3.7)
thin (1.5.1)
thor (0.18.1, 0.14.6)
thread_safe (0.1.2)
tilt (1.4.1)
treetop (1.4.14)
turbolinks (1.3.0)
tzinfo (0.3.37)
uglifier (2.1.2)
vulcan (0.8.2)

Does anyone can help me to find where problem is?

Last edited by exortus (2013-08-09 06:35:54)