Topic: Rails upgrade and Rails App Upgrade

So I upgraded rails (via its gem) on my system but now I get a ton of errors on my Rails app.

Is there an easy way to upgrade the app framework files (boot.rb, environment.rb etc) as well?

Re: Rails upgrade and Rails App Upgrade

Would you mind sharing us the errors you receive?  What happens when you type in "rails -v", "ruby -v", or "gem -v"?

Re: Rails upgrade and Rails App Upgrade

Sure first the diagnostics:

C:\Documents and Settings\Mike>rails -v
Rails 1.2.3

C:\Documents and Settings\Mike>ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]

C:\Documents and Settings\Mike>gem -v
0.9.2

I can't remember what my old versions of rails and ruby were.

here are some sample errors:

DEPRECATION WARNING: The :dependent => true option is deprecated and will be removed from Rails 2.0.  Please use :dependent => :destroy instead.  See http://www.rubyonrails.org/deprecation for details.  See http://www.rubyonrails.org/deprecation for details. (called from has_many at C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/associations.rb:558)
DEPRECATION WARNING: observer is deprecated and will be removed from Rails 2.0  See http://www.rubyonrails.org/deprecation for details. (called from C:/mike/workspace/boomstrap/config/../app/controllers/users_controller.rb:5)
DEPRECATION WARNING: depend_on is deprecated and will be removed from Rails 2.0  See http://www.rubyonrails.org/deprecation for details. (called from observer_without_deprecation at C:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/deprecated_dependencies.rb:29)
DEPRECATION WARNING: observer is deprecated and will be removed from Rails 2.0  See http://www.rubyonrails.org/deprecation for details. (called from C:/mike/workspace/boomstrap/config/../app/controllers/users_controller.rb:5)
DEPRECATION WARNING: depend_on is deprecated and will be removed from Rails 2.0  See http://www.rubyonrails.org/deprecation for details. (called from observer_without_deprecation at C:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/deprecated_dependencies.rb:29)
DEPRECATION WARNING: The :dependent => true option is deprecated and will be removed from Rails 2.0.  Please use :dependent => :destroy instead.  See http://www.rubyonrails.org/deprecation for details.  See http://www.rubyonrails.org/deprecation for details. (called from has_many at C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/associations.rb:558)
DEPRECATION WARNING: end_form_tag is deprecated and will be removed from Rails 2.0  See http://www.rubyonrails.org/deprecation for details. (called from _run_rhtml_47app47views47picks47my_picks46rhtml at C:/mike/workspace/boomstrap/config/../app/views/picks/my_picks.rhtml:23)
DEPRECATION WARNING: The :dependent => true option is deprecated and will be removed from Rails 2.0.  Please use :dependent => :destroy instead.  See http://www.rubyonrails.org/deprecation for details.  See http://www.rubyonrails.org/deprecation for details. (called from has_many at C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/associations.rb:558)
DEPRECATION WARNING: end_form_tag is deprecated and will be removed from Rails 2.0  See http://www.rubyonrails.org/deprecation for details. (called from _run_rhtml_47app47views47picks47my_picks46rhtml at C:/mike/workspace/boomstrap/config/../app/views/picks/my_picks.rhtml:23)
DEPRECATION WARNING: The :dependent => true option is deprecated and will be removed from Rails 2.0.  Please use :dependent => :destroy instead.  See http://www.rubyonrails.org/deprecation for details.  See http://www.rubyonrails.org/deprecation for details. (called from has_many at C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/associations.rb:558)

I guess I should be clearer these are warnings not errors.

The thing is there's nothing on that depreciation link that mentions these.  Also some I tried to fix but it still spews warnings.  Also note at least one of those is from the rails core.