Topic: I get Error while booting webrick. Please help me out....

Hi

I get an error while booting the Webrick. I dont know where Am i wrong. Please help me out. I have another application which is booting up fine while I het error in this. What could be wrong?


C:\>ruby "c:\program files\apache group\apache2\htdocs\Testapp\script\server"
=> Booting WEBrick...
c:/ruby/lib/ruby/1.8/pathname.rb:341:in `lstat': No such file or directory - /C:
/c:/program files/apache group/apache2/htdocs/Testapp/script/../config (Errno::E
NOENT)
        from c:/ruby/lib/ruby/1.8/pathname.rb:341:in `realpath'
        from c:/program files/apache group/apache2/htdocs/Testapp/script/../conf
ig/../vendor/plugins/backgroundrb/lib/middleman_rails_init.rb:2
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:495:in `require'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:495:in `new_constants_in'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:495:in `require'
        from c:/program files/apache group/apache2/htdocs/Testapp/script/../conf
ig/../vendor/plugins/backgroundrb/init.rb:2:in `load_plugin'
         ... 21 levels...
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/server.rb:3
9
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from c:/program files/apache group/apache2/htdocs/Testapp/script/server:
3

C:\>



Thanks
Janakiraman

Re: I get Error while booting webrick. Please help me out....

Reinstall Rails.

Re: I get Error while booting webrick. Please help me out....

I tried reinstalling rails. But still I get an error. Should I use an linux OS. Currently I'm using windows. It says unix server is required.The error is as follows:

C:\>ruby "c:\program files\apache group\apache2\htdocs\Testapp\script\server"
=> Booting WEBrick...
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/webrick.rb:11: w
arning: already initialized constant OPTIONS
=> Booting WEBrick...
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/webrick.rb:11: w
arning: already initialized constant OPTIONS
c:/ruby/lib/ruby/1.8/drb/unix.rb:5: UNIXServer is required (LoadError)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:495:in `require'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:342:in `new_constants_in'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:495:in `require'
        from c:/ruby/lib/ruby/1.8/drb/drb.rb:796:in `auto_load'
        from c:/ruby/lib/ruby/1.8/drb/drb.rb:787:in `uri_option'
        from c:/ruby/lib/ruby/1.8/drb/drb.rb:1044:in `initialize'
         ... 31 levels...
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/server.rb:3
9
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `re
quire'
        from c:/program files/apache group/apache2/htdocs/Testapp/script/server:
3



Please help me out from getting rid of this problem

Thanks
Janakiraman

Re: I get Error while booting webrick. Please help me out....

Hi Janex,
I am actually having the same issue, but it is currently on the back burner for me.  I did notice in your first post:

"from c:/program files/apache group/apache2/htdocs/Testapp/script/../conf
ig/../vendor/plugins/backgroundrb/lib/middleman_rails_init.rb:2"

Looks like you are running the backgroundrb plug-in, I am also on windows (XP/ruby 1.8.5/rails 1.2.3), and have been having issues with that plug-in.

This is not a solution, but if you comment out
#require 'middleman_rails_init'
the init.rb file for the backgroundrb plug-in, you should be able to get the server to start. If that's the case, at least you have an idea of where the problem is.  I haven't had a chance to look into backgroundrb much, but if you find a solution let me know.  smile

-c

Re: I get Error while booting webrick. Please help me out....

cstuss wrote:

This is not a solution, but if you comment out
#require 'middleman_rails_init'
the init.rb file for the backgroundrb plug-in, you should be able to get the server to start. If that's the case, at least you have an idea of where the problem is.  I haven't had a chance to look into backgroundrb much, but if you find a solution let me know.  smile

backgroundrb is not supported under windows (I'm having this issue too and found the answer elsewhere, but since my google-fu led me here first, I thought I'd update this thread.)