Topic: toolbocks_date_select not working

I'm using the toolbock date select widget to set a date of birth. The widget itself displays nicely and without any error. Unfortunately the date is not set in the model.

Here's the view:

<% form_for (:proband, :url => proband_path(@proband), :html => { :method => :put }) do |f| %>
<%= toolbocks_date_select :proband, :date_of_birth, :help => false %>
<% end %>

The params object doesn't contain a date value.

When I replace toolbocks_date_select with Rails' default date_select then everything works just fine.

Any ideas ?

Re: toolbocks_date_select not working

hmm, did you dump params, nothing there at all? maybe rename your column from date_of_birth to something else and try, could be a naming issue with datebocks or something, try something simple like mydob..


Re: toolbocks_date_select not working

Solved it. The problem was that the order in which the JavaScript libraries were imported was wrong. I put 'datetime_toolbocks' to the last position and now it works.