Topic: New Rails Install won't work

Help.

I was trying to upgrade my current install on a windows XP machine.

I blew away my ruby install to start fresh.  Installed Ruby from the onestep installer (ruby186-25.exe) and then used gem to install rails. (gem install rails --include-dependencies)

Rails successfully installed but I now keep getting this error when I do anything with the rails command ("rails testapp", or even "rails --version")

/usr/lib/ruby/site_ruby/1.8/rubygems.rb:301:in `report_activate_error': Could no
t find RubyGem rails (> 0) (Gem::LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:238:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:76:in `active_gem_with_opti
ons'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:50:in `gem'
        from C:/ruby/bin/rails:15

this has me at a complete loss. I've checked that RUBYOPT is set to rubygems (it is) and I can't figure out anything else.

Last edited by bitdamaged (2007-05-08 13:59:01)

Re: New Rails Install won't work

Could not find RubyGem rails

Reinstall Rails.

Re: New Rails Install won't work

yeah okay done. same error.