Topic: Errors starting webbrick after Rails 1.2.3 upgrade

Hi Rails community:

rails -v    => Rails 1.2.3
ruby -v     => ruby 1.8.5
gem -v      => 0.9.2

After upgrading rails to 1.2.3 using "gem install rails --include-dependencies" and changing RAILS_GEM_VERSION = '1.2.3' I get the following errors when starting WEBrick.

What am I doing wrong or what's wrong?

Thanks for any hints to solve this and for your help,
Thomas


./script/../config/boot.rb:29:Warning: require_gem is obsolete.  Use gem instead.
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- openssl (MissingSourceFile)
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6752/lib/active_support/dependencies.rb:495:in `require'
    from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6752/lib/active_support/dependencies.rb:342:in `new_constants_in'
    from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6752/lib/active_support/dependencies.rb:495:in `require'
    from /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3.6752/lib/action_controller/session/cookie_store.rb:4
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require'
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:32:in `require'
    from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2.6752/lib/active_support/dependencies.rb:495:in `require'
     ... 23 levels...
    from ./script/server:2:in `require'
    from ./script/server:2
    from -e:4:in `load'
    from -e:4

Re: Errors starting webbrick after Rails 1.2.3 upgrade

OK, I found the answer in this post: http://railsforum.com/viewtopic.php?id=3332
What worked for me was to re/install libgems-ruby1.8, which also installs libopenssl-ruby1.8 among it's dependencies.
Works fine now.

Thomas