Topic: Error message trying to run 'rake test' after rails upgrade
I get the following error after I upgraded to rails 1.2.3-2.0 on Debian when I try to run 'rake test'.
/usr/lib/ruby/1.8/rubygems/version.rb:296:in `parse': Illformed requirement [~>1.2.3-2.0] (ArgumentError)
I updated config/environment.rb to reflect the upgrade, and it seems to work when I run 'rake db:migrate'. I also tried editing the config to be 1.2.3 without the postfix 2.0, but that results in rails not being found when I run 'rake db:migrate'. I'm using Ruby version 1.8.6. Anyone have an idea what could be wrong?