Topic: Deployment Problem using Capistrano and Mediatemple

Hello,

I am having some crazy errors trying to deploy my app onto my server at MediaTemple using Capistrano.

Clout:~/Sites/rubyDevelopment/modpile adamkirkwood$ cap deploy
  * executing task deploy
  * executing task update
** transaction: start
  * executing task update_code
  * querying latest revision...
Password:
  * executing "if [[ ! -d /home/6547/containers/rails/modpile/releases/20070409082332 ]]; then\n              svn co --no-auth-cache   -q -r1 svn+ssh://serveradmin%xilo32.com@xilo32.com/home/6547/data/svn/modpile/trunk /home/6547/containers/rails/modpile/releases/20070409082332 &&\n              (test -e /home/6547/containers/rails/modpile/revisions.log || (touch /home/6547/containers/rails/modpile/revisions.log && chmod 666 /home/6547/containers/rails/modpile/revisions.log)) && echo `date +\"%Y-%m-%d %H:%M:%S\"` $USER 1 20070409082332 >> /home/6547/containers/rails/modpile/revisions.log;\n            fi"
    servers: ["xilo32.com"]
    [xilo32.com] executing command
** [out :: xilo32.com] Password:
** [out :: xilo32.com] subversion is asking for a password
** [out :: xilo32.com] Password:
** [out :: xilo32.com] subversion is asking for a password
    command finished
  * executing task set_permissions
  * executing "chmod -R g+w /home/6547/containers/rails/modpile/releases/20070409082332"
    servers: ["xilo32.com"]
    [xilo32.com] executing command
    command finished
  * executing "rm -rf /home/6547/containers/rails/modpile/releases/20070409082332/log /home/6547/containers/rails/modpile/releases/20070409082332/public/system &&\n    ln -nfs /home/6547/containers/rails/modpile/shared/log /home/6547/containers/rails/modpile/releases/20070409082332/log &&\n    ln -nfs /home/6547/containers/rails/modpile/shared/system /home/6547/containers/rails/modpile/releases/20070409082332/public/system"
    servers: ["xilo32.com"]
    [xilo32.com] executing command
** [out :: xilo32.com] ln:
** [out :: xilo32.com] creating symbolic link `/home/6547/containers/rails/modpile/releases/20070409082332/public/system' to `/home/6547/containers/rails/modpile/shared/system'
** [out :: xilo32.com] : No such file or directory
    command finished
*** [set_permissions] transaction: rollback
  * [set_permissions] rolling back
  * [update_code] rolling back
  * executing "rm -rf /home/6547/containers/rails/modpile/releases/20070409082332"
    servers: ["xilo32.com"]
    [xilo32.com] executing command
    command finished
command "rm -rf /home/6547/containers/rails/modpile/releases/20070409082332/log /home/6547/containers/rails/modpile/releases/20070409082332/public/system &&\\\n    ln -nfs /home/6547/containers/rails/modpile/shared/log /home/6547/containers/rails/modpile/releases/20070409082332/log &&\\\n    ln -nfs /home/6547/containers/rails/modpile/shared/system /home/6547/containers/rails/modpile/releases/20070409082332/public/system" failed on xilo32.com
Clout:~/Sites/rubyDevelopment/modpile adamkirkwood$

By any chance someone could point me in a good direction as to figuring out this mess?

Thanks in advance.

Re: Deployment Problem using Capistrano and Mediatemple

I'm getting the same thing deploying to media temple at the moment.
Have you figured anything out?

Re: Deployment Problem using Capistrano and Mediatemple

I actually have not been successful using Cap on MT.  Very sad.

Re: Deployment Problem using Capistrano and Mediatemple

I published a recipe for MT that I've been using here:

http://www.almosteffortless.com/2007/01 … ia-temple/

That was working about a week or two ago, but I've been moving over to Slicehost and haven't tried it out lately.

Re: Deployment Problem using Capistrano and Mediatemple

Cheers trevor, i'll give it a go