Topic: Problem installing Rails in OSX

First of all, I'm doing this on a dialup connection.
Secondly, I've done this flawlessly on Windows XP multiple times
I'm using this tutorial: … -mysql-osx

When I get to the step to install Rails through gems I type in Terminal:
sudo gem install rails --include-dependencies
after it takes awhile going out to update off of gems.rubyforge.something it comes back and says that it cannot find a gem called rails on any repository.
It does this every time.
I've tried manually downloading the rails-1.2.3.gem file and installing off that but then I don't get the dependencies, and the very first one it tells me to install (application-something) installs fine as version 1.4.2, but then when I try to install rails again it tells me it needs that same application-something gem but this time version 1.15.3 instead...
anyone ever had these problems?
could it have anything to do with me doing this over dialup?

Re: Problem installing Rails in OSX

Pselus wrote:

could it have anything to do with me doing this over dialup?

I think so. I get this message when doing it over a slow DSL connection. It usually works on the 2nd time I run the command. My guess is that it's timing out before it updates the list of available gems. Try running the command several times and see if it finally works.

Railscasts - Free Ruby on Rails Screencasts

Re: Problem installing Rails in OSX

Btw, is the description at hivelogic (link from the first post in this thread) still the 'recommended' way of installing rails? I know I had problems installing rails without XCode some months ago (my hard disk was so full I had no free space for xcode left), and as I'm switching to a new Mac in a few days I'll have to reinstall everything. So, shall I use Fink/DarwinPorts/MacPorts? Any other link you'd want to share that might be newer?