Topic: Problems starting webrick/mongrel with rails 1.2.3

When ever I try to start webrick or mongrel I get this error. What did I mess up? It was working fine.

G:\sites\college>ruby script/server webrick
=> Booting WEBrick...
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/webrick.rb:11: w
arning: already initialized constant OPTIONS
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
Exiting
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/mongrel.rb:15: w
arning: already initialized constant OPTIONS
d:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/mongrel.rb:18: u
ndefined method `options' for []:Array (NoMethodError)
        from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `ge
m_original_require'
        from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `re
quire'
        from d:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:495:in `require'
        from d:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:342:in `new_constants_in'
        from d:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_suppo
rt/dependencies.rb:495:in `require'
        from d:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/server.rb:3
9
        from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `ge
m_original_require'
        from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `re
quire'
        from script/server:3


What is OPTIONS?

http://www.brianthecoder.com

Rails, Javascript, Actionscript and More.

Re: Problems starting webrick/mongrel with rails 1.2.3

Check your versions against 'gems list'.

When I corrected my entries in environment.rb this problem went away.