Topic: How to connect to SQL SERVER 2000 Using Rails

I am trying to connect to SQL SERVER 2000 using rails and it is always giving me exceptions.

Here is my database.yml file:

development:
  adapter:sqlserver
  database:School
  host:DBI:ADO:Provider=SQLOLEDB;Data Source=localhost;InitialCatalog=School;Integrated Security=SSPI;

Now I run the following command:

ruby script/generate scaffold Users Admin

And here is the exception being thrown:

C:\work\demo>ruby script/generate scaffold Users Admin
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_
adapters/abstract/connection_specification.rb:204:in `establish_connection': ada
pter:sqlserver database:School host:DBI:ADO:Provider=SQLOLEDB;Data Source=localh
ost;InitialCatalog=School;Integrated Security=SSPI; database is not configured (
ActiveRecord::AdapterNotSpecified)
        from c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_recor
d/connection_adapters/abstract/connection_specification.rb:202:in `establish_con
nection'
        from c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_recor
d/connection_adapters/abstract/connection_specification.rb:195:in `establish_con
nection'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:229:i
n `initialize_database'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:88:in
`process'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in
`send'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in
`run'
        from ./script/../config/../config/environment.rb:13
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/generate.rb
:1
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from script/generate:3

Any ideas what is going on here?