Topic: Depreciation Question

Howdy Fellas -

I just received this warning in my development.log:

DEPRECATION WARNING: server_settings has been renamed smtp_settings, this warning will be removed with rails 2.0  See http://www.rubyonrails.org/deprecation for details. (called from send at /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:328)

Of course, checking http://www.rubyonrails.org/depreciation doesn't say ANYTHING about smtp_settings or server_settings (used for sending e-mails from the system).

So my question is:

Is smtp_settings available NOW in the current release of rails?  Does it work the same?  Is it documented somewhere?  If not, will server_settings break if/when I upgrade to rails 2.0?

Thanks guys.

Re: Depreciation Question

It is available now in the current release, and will work fine apart from the warnings. In Rails 2.0 though it will be removed, so when you upgrade, your code will break.

The official Rails deprecation is a bit feeble; my advice would be to do what the warning says when its straightforward, Google it when its not.

Alex