Topic: Application error on load - then refresh and its fine!

Hi people - newbie here! - not sure if this is in the right place but looks like a good starting point!

I have built my app - it works fine (www.oneorangemonkey.com) its running in production mode under fast cgi (site5) and nothing seems to be out of place... BUT...

The first time you hit the site it shows an application error message and then if you refresh the page everything is fine again.


site5 support say that my error log shows the following...



ActionController::RoutingError (no route found to match "/new" with {:method=>:get}):
    /vendor/rails/actionpack/lib/action_controller/routing.rb:1292:in `recognize_path'
    /vendor/rails/actionpack/lib/action_controller/routing.rb:1282:in `recognize'
    /vendor/rails/railties/lib/dispatcher.rb:40:in `dispatch'
    /vendor/rails/railties/lib/fcgi_handler.rb:168:in `process_request'
    /vendor/rails/railties/lib/fcgi_handler.rb:143:in `process_each_request!'
    /vendor/rails/railties/lib/fcgi_handler.rb:109:in `with_signal_handler'
    /vendor/rails/railties/lib/fcgi_handler.rb:142:in `process_each_request!'
    /usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:612:in `each_cgi'
    /usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:609:in `each_cgi'
    /vendor/rails/railties/lib/fcgi_handler.rb:141:in `process_each_request!'
    /vendor/rails/railties/lib/fcgi_handler.rb:55:in `process!'
    /vendor/rails/railties/lib/fcgi_handler.rb:25:in `process!'
    dispatch.fcgi:24

and the followup was....

It almost seems like a different function is being called the second time the page is loaded.  The first function causes the error and then subsequent refreshes load a different function which doesn't have any problems.  However, the first function is encountering problems and causes the entire page to not load.



This would be great if i knew how to fix this but im lost - any help would be massivly appreciated!

Thanks..
Monkey