Topic: RAD Rails - plugin installation

Hello,

I am new to this forum and new with Rails, so I apologize if I ask stupid question.
Here is my first :
- I have installed RoR with the Radrails IDE to start learning rails. Looking at the way to paginate a result I saw that the standard method was about to be deprecated and that I shoul use the plugin will_paginate instead. My problem is that I don't know how to install a plugin with Rad rail.

I eventually saw a command line to execute (/script/plugin install \ svn://errtheblog.com/svn/plugins/will_paginate) but I don't know where/how to run it.
I tried (on windows XP) to run "ruby.exe" and type this command line but nothing happened.
Thanks in advance for your help

Re: RAD Rails - plugin installation

I run RadRails as a plugin within Eclipse, which is found at http://www.eclipse.org/. I'm not sure if this is a feature of Eclipse, but I don't think it is.

In my RadRails, there is a tab at the bottom that says Console. In it, I can execute ruby commands. As long as your RadRails knows your configuration settings for Ruby and Rails and so on, you should be able to do this as well, as far as I know. If you see that tab, open it and enter the command there.

Re: RAD Rails - plugin installation

Thanks, in fact I read on the aptana forum that in the current version it was not possible to include a new plugin.
And it was a stupid question, I found the answer to install the plugin manually (RTFM) wink

Re: RAD Rails - plugin installation

tranquiliste wrote:

Hello,

I am new to this forum and new with Rails, so I apologize if I ask stupid question.
Here is my first :
- I have installed RoR with the Radrails IDE to start learning rails. Looking at the way to paginate a result I saw that the standard method was about to be deprecated and that I shoul use the plugin will_paginate instead. My problem is that I don't know how to install a plugin with Rad rail.

I eventually saw a command line to execute (/script/plugin install \ svn://errtheblog.com/svn/plugins/will_paginate) but I don't know where/how to run it.
I tried (on windows XP) to run "ruby.exe" and type this command line but nothing happened.
Thanks in advance for your help

Go to the base directory of your application and run the

command script/plugin install svn://errtheblog.com/svn/plugins/will_paginate

and it will install that plugin into the rails environment for that application and you should then be able to use any function that the plugin brings with it.