Topic: ./script/server problem

i have a project that does not properly load the lighttpd server. when i try to force webrick it falls back to lighttpd.

virgin rails apps loads lighttpd perfectly and forcing webrick works perfectly too.

my environment is gentoo, the original environment for the project i'm having trouble with is OS X

here is the output from ./script/server:

$ ./script/server
=> Booting lighttpd (use 'script/server webrick' to force WEBrick)
=> Rails application started on http://0.0.0.0:3001
=> Call with -d to detach
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
2006-10-11 18:16:02: (mod_fastcgi.c.1022) execve failed for: /home/franco/workspace/mirror/public/dispatch.fcgi Not a directory
2006-10-11 18:16:02: (mod_fastcgi.c.1048) the fastcgi-backend /home/franco/workspace/mirror/public/dispatch.fcgi failed to start:
2006-10-11 18:16:02: (mod_fastcgi.c.1052) child exited with status 20 /home/franco/workspace/mirror/public/dispatch.fcgi
2006-10-11 18:16:02: (mod_fastcgi.c.1055) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
For more information check http://www.lighttpd.net/documentation/f … gi-program
2006-10-11 18:16:02: (mod_fastcgi.c.1060) If this is PHP on Gentoo add fastcgi to the USE flags
2006-10-11 18:16:02: (mod_fastcgi.c.1356) [ERROR]: spawning fcgi failed.
2006-10-11 18:16:02: (server.c.834) Configuration of plugins failed. Going down.
Exiting

Re: ./script/server problem

SOLVED
public/dispatch.fcgi had #!/usr/local/bin/ruby
i needed to change it to #!/bin/env ruby
but i accidentally changed it to #!/bin/env/ruby

its now loading fine and forcing webrick fine