Topic: Juggernaut help

I am trying to get the juggernaut push server started.  I installed the eventmachine gem, then juggernaut, then ran ruby script/push_server and got the following:

[~/railsapps/test]# ruby script/push_server
Starting Juggernaut Push Server
Port: 443
/home/bellview/.gems/gems/eventmachine-0.9.0/lib/eventmachine.rb:493:in `start_tcp_server': no acceptor (RuntimeError)
        from /home/bellview/.gems/gems/eventmachine-0.9.0/lib/eventmachine.rb:493:in `start_server'
        from script/push_server:300
        from /home/bellview/.gems/gems/eventmachine-0.9.0/lib/eventmachine.rb:1030:in `call'
        from /home/bellview/.gems/gems/eventmachine-0.9.0/lib/eventmachine.rb:1030:in `event_callback'
        from /home/bellview/.gems/gems/eventmachine-0.9.0/lib/eventmachine.rb:223:in `run_machine'
        from /home/bellview/.gems/gems/eventmachine-0.9.0/lib/eventmachine.rb:223:in `run'
        from script/push_server:299

Anyone have experience using juggernaut and the eventmachine gem?  I am stuck.

Last edited by LeeQ (2007-10-31 15:07:51)

Re: Juggernaut help

hey man!

Are you running this locally, or elsewhere...

I'm assuming its local...

You know, it seems like I had this problem way back in september or august...

Unfortunately, I cannot for the life of me how I solved it...

would you mind posting your Juggernaut.yml file?  I kinda have a feeling it has something to do with your push_host, or your push_post.  I never had any luck with 443, but 1055 always worked.  So try that.

Also, check out the google group for juggernaut.


Last edited by levicole (2007-11-23 02:14:51)