Topic: Editors for OS X 10.3 and below

TextMate and RadRails both require a minimum of OS X 10.4. I'm on 10.3, and I've been using TextWrangler (the free version of BBEdit) for my main text editor. But it has no knowledge of Ruby beyond syntax highlighting, and I'm really missing things like integrated documentation and auto-completion. Is there anyone out there using a good editor or IDE that runs on 10.3? I'd even try old builds of software that's transitioned 10.4 and above, but they can be hard to find. I had to download RadRails to figure out it required 10.4, because that information wasn't anywhere I could find on their website.

Re: Editors for OS X 10.3 and below

The old version of Smultron supports Panther, but it isn't any better than TextWrangler. Most Mac developers assume people are at least on Tiger by now; that's why there isn't much support for 10.3 and earlier.