Topic: Uploaded images won't display in IE6?

Sorry for the long post, but I'm at wit's end trying to figure this out, so I thought another set of eyes could help see what I'm missing.

I'm using attachment_fu to handle the uploading with product images going to "/uploads/stamps/" and profile images going to "/uploads/users/". FireFox, IE7, Safari, and Opera work great, but they simply won't load in IE6 and below.

I've checked the permissions of the images, uploads, stamps, and users folders and verified that the folders have permissions set to 755 and the images within those folders have permissions set to 644. I've also disabled page caching in the corresponding controllers.

My .htaccess file looks like this:
# General Apache options
# AddHandler fastcgi-script .fcgi
# AddHandler cgi-script .cgi
Options +FollowSymLinks +ExecCGI

# If you don't want Rails to look in certain directories,
# use the following rewrite rules so that Apache won't rewrite certain requests
#
# Example:
#   RewriteCond %{REQUEST_URI} ^/notrails.*
#   RewriteRule .* - [L]

# Redirect all requests not available on the filesystem to Rails
# By default the cgi dispatcher is used which is very slow
#
# For better performance replace the dispatcher with the fastcgi one
#
# Example:
#   RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]
RewriteEngine On

# If your Rails application is accessed via an Alias directive,
# then you MUST also set the RewriteBase in this htaccess file.
#
# Example:
#   Alias /myrailsapp /path/to/myrailsapp/public
#   RewriteBase /myrailsapp

RewriteRule ^$ index.html [QSA]
RewriteRule ^([^.]+)$ $1.html [QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

# In case Rails experiences terminal errors
# Instead of displaying this message you can supply a file here which will be rendered instead
#
# Example:
#   ErrorDocument 500 /500.html

ErrorDocument 500 "<h2>Application error</h2>Rails application failed to start properly"


Any help or pointers would be greatly appreciated.

Re: Uploaded images won't display in IE6?

I don't think it has anything to do with your .htaccess file if all the other browsers are able to see your images.  You can add RewriteLog and RewriteLogLevel directives after the RewriteEngine On line and see that they are matching correctly. Add the following and post some of the results.
RewriteLog <path>
RewriteLogLevel 9

Re: Uploaded images won't display in IE6?

Thanks for the help and suggestion, but alas it all boils down to my own error. I'm on the mac side but use paralles and multiple versions of IE to test on, so long story short is that I was testing in a stand-alone version of IE6 which didn't like interacting with other versions of explorer installed. I re-installed windows to get back to a native IE6 and everything works as expected.

Just another example of long hours, tired eyes, and overlooking the easiest answer.