Topic: HOWTO: install will_paginate plugin

Hi!
I just switched to Rails 2.0 and can't install will_paginate plugin. I've downloaded 2.0.2 Rails.
I tried:
ruby script/plugin install svn://errtheblog.com/svn/plugins/will_paginate
(this is the only link i found)
but nothing happens. i mean, i somehow got the directory for the plugin created, but the plugin is not installed/downloaded. Can anyone help?

Re: HOWTO: install will_paginate plugin

That is because you're running Windows. Windows does not have an SVN client by default so script/plugin will hang.

You can get a copy of will_paginate from: http://www.frozenplague.net/plugins/will_paginate.rar

You can open it with WinRAR.

Re: HOWTO: install will_paginate plugin

Thanks a lot!
I've spent now ~15 hours trying to move my small homepage to RoR 2.0.... but it's seems worth it smile

Re: HOWTO: install will_paginate plugin

You can download will_paginate from the official repo (there is a "download" button).

But, I recommend the gem. There are extensive installation instructions on the wiki.

Re: HOWTO: install will_paginate plugin

You could also install SVN on your machine so you don't have that problem again.  Check out this tutorial, http://weblogs.asp.net/nleghari/article … sion.aspx.  I've used it when I was running Windows for awhile.  My other idea is to dump the Windows machine and move to a Mac. smile