Topic: Ruby on Rails with XCode

I am trying to follow the Apple tutorial article here:

http://developer.apple.com/tools/develo … opard.html

But when I try to start my server from the shell command I get:

[Session started at 2008-03-04 18:24:22 -0500.]
Missing the Rails 2.0.2 gem. Please `gem install -v=2.0.2 rails`, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.

The Debugger has exited with status 1.The Debugger has exited with status 1.

has anyone else run into this.  My gems are up to date:

*** LOCAL GEMS ***

actionmailer (2.0.2)
actionpack (2.0.2)
actionwebservice (1.2.6)
activerecord (2.0.2)
activeresource (2.0.2)
activesupport (2.0.2)
capistrano (1.4.1)
cgi_multipart_eof_fix (2.1)
daemons (1.0.6)
fastthread (1.0)
gem_plugin (0.2.2)
login_generator (1.2.2)
mongrel (1.0.1)
mysql (2.7)
needle (1.3.0)
net-sftp (1.1.0)
net-ssh (1.1.1)
rails (2.0.2)
rake (0.8.1)
RedCloth (3.0.4)
ruby-debug (0.9.3)
ruby-debug-base (0.9.3)
rubygems-update (1.0.1)
sources (0.0.1)
sqlite3-ruby (1.2.1)
termios (0.9.4)


I am new to tall this coming from a procedural programming background on AS/400's

Any help is much appreciated.  I am on 10.5.2 of MacOS X.

Thanks,

Rob

Re: Ruby on Rails with XCode

I also posted this issue on the Apple developer forums and received a reply that fixed my problem.  I thought I would share it with everyone here in case someone else is having the same issue.  The only thing I would add is I had to do a restart before things started working for me.

================================================
I had the same problem. I'm not sure if this will completely fix things, because I just found this, but I had a problem with an apparent two installations of rails. One in /usr/local/bin/, and one in /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/. So, I ran those update commands like this:

$ sudo /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem update --system
$ sudo /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem install rails
$ sudo /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem update rake
$ sudo /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem update sqlite3-ruby

After running those, script/server ran correctly in Xcode.
================================================

Rob